×
Inicio Galería Aleatorio Contacto

Requisitos para symfony5

Sección: Symfony

Creado: 22-02-21 (Actualizado: 22-02-21)

Requisitos

GIT

sudo apt install git
git config --global user.email "email"
git config --global user.name "Name

PHP

install php7.4-cli

Se deberán instalar otros paquetes como php7.4-xml.

COMPOSER

sudo apt install composer

Para instalar la última versión

wget https://getcomposer.org/installer -O - -q | php -- --quiet
sudo mv composer.phar /usr/local/bin/composer

SYMFONY-CLI

wget https://get.symfony.com/cli/installer -O - | bash
alias sf="~/.symfony/bin/symfony [email protected]"

Si queremos usar symfony server:ca:install necesitamos instalar libnss3-tools.

DOCKER

curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
sudo add-apt-repository \
   "deb [arch=amd64] https://download.docker.com/linux/ubuntu \
   $(lsb_release -cs) \
   stable"

Al instalar en linux mint es necesario poner el equivalente de ubuntu (ulyssa es focal) https://linuxmint.com/download_all.php

sudo apt-get install docker-ce docker-ce-cli containerd.io
sudo usermod -aG docker $USER

DOCKER COMPOSE

sudo pip3 install docker-compose

DOCKER COMMAND LINE COMPLETION

sudo curl -L https://raw.githubusercontent.com/docker/compose/1.28.0/contrib/completion/bash/docker-compose -o /etc/bash_completion.d/docker-compose

VSCODE

https://blog.softhints.com/install-visual-studio-code-linux-mint/

wget -qO- https://packages.microsoft.com/keys/microsoft.asc | gpg --dearmor > packages.microsoft.gpg
sudo install -o root -g root -m 644 packages.microsoft.gpg /etc/apt/trusted.gpg.d/
sudo sh -c 'echo "deb [arch=amd64 signed-by=/etc/apt/trusted.gpg.d/packages.microsoft.gpg] https://packages.microsoft.com/repos/vscode stable main" > /etc/apt/sources.list.d/vscode.list'

update

install code

NPM

sudo apt install npm

YARN

Hay varias formas de instalación (npm, shell y repos)

https://tecadmin.net/install-yarn-debian/

curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
update && sudo apt install yarn
yarn --version

Raspbian

https://yarnpkg.com/

npm install -g yarn

SYMFONY PROXY

Set the following URL as the value of the Automatic Proxy Configuration: http://127.0.0.1:7080/proxy.pac

symfony proxy:start
cd my-project/
symfony proxy:domain:attach my-domain

En Raspbian

Opción 1 (parece mejor)

https://devdojo.com/bobbyiliev/how-to-install-docker-and-docker-compose-on-raspberry-pi

Opción 2

https://linuxhint.com/install_docker_on_raspbian_os/

sudo apt install raspberrypi-kernel raspberrypi-kernel-headers

curl -sSL https://get.docker.com | sh

sudo usermod -aG docker pi

Raspbian

sudo pip3 install docker-compose

Siguiente Publicación